Pourquoi est-il impossible d’installer une mise à jour sur les Moverio BT-200 ?

Pourquoi est-il impossible d’installer une mise à jour sur les Moverio BT-200 ?

Ordinateurs, smartphones, tablettes, montres…, les objets connectés arrivent à relever de nouveaux défis à chaque itération. La présence de mises à jour est donc essentielle pour apporter à la fois ces nouveautés ou encore pour corriger des bugs plus ou moins importants. Les lunettes connectées ne dérogent pas à la règle et le modèle d’Epson non plus. En se rendant dans les paramètres des Moverio BT-200, il est ainsi possible de vérifier l’existence d’une mise à jour (Informations sur l’appareil -> Mises à jour système).

Une demande est alors faite vers les serveurs d’Epson pour savoir si une version plus récente du système est disponible. Si vos lunettes sont fraichement arrivées, elles seront alors en R1.0.0 et une mise à jour D1.0.x (D1.0.5 au moment de la rédaction de cet article) vous sera proposée. Tout est réalisé en OTA (Over The Air), c’est-à-dire que le fichier est téléchargé directement sur les lunettes et appliqué aussitôt. Cela évite ainsi de passer par un ordinateur.

Malheureusement, vous remarquez qu’il est impossible de l’installer, quelle que soit la qualité de votre connexion. La raison est simple : vous ne pouvez pas installer des mises à jour de développement sur des lunettes en version stable. En effet, le nom de version contient un R (pour Release) dans la version stable et un D (pour Development) dans sa mouture dédiée aux développeurs. Ne vous inquiétez donc pas de l’impossibilité d’appliquer un patch si un fichier commençant par la lettre D vous est proposé. Il est toutefois dommage qu’Epson n’ait pas différencié ses mises à jour à travers des canaux différents, car un nouvel utilisateur risque de ne pas comprendre l’erreur.

Pour résumer, si vous venez d’acheter les lunettes d’Epson et que vous ne souhaitez pas développer avec, seules les mises à jour commençant par un R seront applicables.

Laisser un commentaire

comment-avatar

*